Back to overview
Downtime
portfolio website down
Nov 16, 2025 at 05:22pm UTC
Affected services
phillsphanbh3.me
Resolved
Nov 16, 2025 at 06:44pm UTC
resolved
Affected services
Updated
Nov 16, 2025 at 05:27pm UTC
monitoring! it auto recovered!
Affected services
Created
Nov 16, 2025 at 05:22pm UTC
We are currently getting 404s on the portfolio website, working on a fix
Affected services