beta website 500, then dns, then 404
Resolved
Nov 23, 2025 at 07:34pm UTC
RESOLVED THANK YOU JESUS!!!
Affected services
Updated
Nov 23, 2025 at 03:30pm UTC
we are still working on a fix with the beta website, we have tried everything, i am going to try and get a few coding friends on to try and resolve this, I am genuenly confused by why and how this issue is NOT resolved
Affected services
Updated
Nov 22, 2025 at 06:53pm UTC
We have just escalated the issue to the entire team including devs, beta testers, and bug hunters to try and get this issue fixed within the next few hours, this is unacceptable for how long this issue is taking.
Affected services
Created
Nov 22, 2025 at 04:30pm UTC
We are aware that the beta website is currently giving out a error 404 code at this time.
Affected services